PayPal Here Issues
Incident Report for Lightspeed
Resolved
This incident has been resolved.
Posted Jun 28, 2021 - 18:29 UTC
Identified
PayPal Here is experiencing a service disruption and there may be issues using that payment type. Please monitor PayPal's status page for updates: https://www.paypal-status.com/product/production
Posted Jun 28, 2021 - 17:30 UTC
This incident affected: Lightspeed Retail (X-Series) (Retail POS, Retail POS for iPadOS).