Email delivery delays
Incident Report for Vend
Resolved
This incident has been resolved.
Posted Sep 06, 2018 - 20:07 UTC
Identified
We have identified an issue with the provider Vend uses to deliver emails. This is causing some emails to be delayed. The provider is working on a fix for this issue.
Posted Sep 06, 2018 - 11:03 UTC