payment through eConduit affected
Incident Report for Lightspeed
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 22:42 UTC
Monitoring
We are no longer getting reports from retailers experiencing payment issues through eConduit. Sorry for any inconvenience that this might have cause you.
Posted Jun 17, 2022 - 21:08 UTC
Investigating
We're currently investigating an issue affecting a few retailers operating payment through eConduit. We'll keep you informed with status updates as they come. Thanks for your patience.
Posted Jun 17, 2022 - 20:07 UTC
This incident affected: Lightspeed Retail (X-Series) (Payments).