Product page not displaying latest information
Incident Report for Vend
Resolved
This incident has been resolved.
Posted Aug 27, 2021 - 14:55 UTC
Monitoring
We have identified an issue where the product page isn't displaying the latest added products. A fix has been implemented and we are monitoring the results. We will keep you posted with updates as they come. Thanks for your patience.
Posted Aug 27, 2021 - 14:34 UTC