Delay processing sales
Incident Report for Lightspeed
Resolved
This incident has been resolved. Apologies for any inconvenience it might have caused you.
Posted May 10, 2022 - 08:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 10, 2022 - 03:39 UTC
Investigating
We’re currently investigating an issue causing retailers to experience delays when processing sales and creating products within their account. Thanks for your patience, we’ll keep you informed with updates as they arise.
Posted May 10, 2022 - 01:49 UTC
This incident affected: Lightspeed Retail (X-Series) (Sales History).