Past-due retailers are unable to access the sell screen
Incident Report for Vend
Resolved
This incident has been resolved.
Posted Jun 11, 2020 - 18:42 UTC
Update
We are continuing to investigate this issue.
Posted Jun 11, 2020 - 15:51 UTC
Investigating
We’re aware of an error some past-due retailers are unable to access the sell screen.
Posted Jun 11, 2020 - 15:50 UTC
This incident affected: POS (Register for Mac & PC, Register for iPad).