The provider we use to process payments is currently experiencing an unscheduled outage.
Incident Report for Vend
Resolved
Issue is now resolved.
Posted Oct 18, 2019 - 18:39 UTC
Identified
We've identified a third-party issue causing errors with Vend-subscription payments related to Visa cards. See https://status.windcave.com for additional information.
Posted Oct 18, 2019 - 15:00 UTC