Email delivery for Vend Ecommerce stores experiencing delays.
Incident Report for Vend
Resolved
This incident has been resolved and all emails are delivered without any delays. Thanks very much for your patience.
Posted Nov 01, 2019 - 07:24 UTC
Identified
Email delivery through Vend Ecommerce stores is currently experiencing delays. We're working to resolve this issue as quickly as possible. We apologise for any inconvenience this may cause.
Posted Nov 01, 2019 - 05:07 UTC
This incident affected: Ecommerce.