Payments system issues
Incident Report for Vend
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 01:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2020 - 01:30 UTC
Investigating
We're aware of an issue that may be affecting payment processing for Vend retailers. Please bear with us while we investigate.
Posted Mar 12, 2020 - 01:19 UTC
This incident affected: POS (Register for Mac & PC, Register for iPad).