Customers page no showing results.
Incident Report for Lightspeed
Resolved
This incident has been resolved.
Posted May 22, 2022 - 09:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results. Customers page should be back online.
Posted May 22, 2022 - 08:54 UTC
Investigating
We are getting reports from some retailers that the customer page is failing to load. The issue seems to be caused by a third party maintenance outside our control. We will update shortly.
Posted May 22, 2022 - 08:03 UTC
This incident affected: Lightspeed Retail (X-Series) (Customer Management).