Product / Customer search not displaying results
Incident Report for Vend
Resolved
All search functionality is fully restored. Thank you for your patience.
Posted Nov 05, 2020 - 21:11 UTC
Update
RESOLVED: Searching for customers, products and historical sales is available. Also searching products by retailer_prices, tags and product_code is now restored.
IN PROGRESS: Searching sales by promo code and notes

Thank you for your patience. We will provide a further status update in due course
Posted Nov 05, 2020 - 03:43 UTC
Update
RESOLVED: Searching for customers, products and historical sales is available
IN PROGRESS: Searching products by retail_prices, tags and product_codes.

Thank you for your patience. We will provide a further status update in due course
Posted Nov 04, 2020 - 21:53 UTC
Update
RESOLVED: Searching for customers, products and historical sales is available
IN PROGRESS: Searching products by retail_prices, tags and product_codes.

Thank you for your patience. We will provide a further status update in due course
Posted Nov 04, 2020 - 20:20 UTC
Update
The restoration of historical sales data in Sales History has been completed.

RESOLVED: Searching for customers and products is now available. As well as searching for historical sales in Sales history.
IN PROGRESS: Searching products by retail_prices, tags and product_codes.

Thank you for your patience. We will provide a further status update in due course
Posted Nov 04, 2020 - 13:27 UTC
Update
We continue to work on searching by tags and products and restoration of historical sales data in Sales History. Please note that sales are searchable in the Sales Ledger as an alternative until the Sales History is restored.

Thank you for your patience. We will provide another update in approximately six hours.
Posted Nov 04, 2020 - 04:28 UTC
Update
The technical issue which resulted in retailers being unable to search by various fields and some sales data not uploading to 'Sales History' has been identified and the root of this issue has been fixed. Our focus now is on restoring full search functionality and delayed data uploads.

RESOLVED: Searching for customers and products is now available.
IN PROGRESS; searching by tags and products and restoration of historical sales data in Sales History. Please note that sales are searchable in the Sales Ledger as an alternative until the Sales History is restored.

Thank you for your patience. We will provide a further status update in due course
Posted Nov 04, 2020 - 01:57 UTC
Update
An update on the status of restoring older data into our search indexes.

We have restored customer searches for all affected retailers, lists of customers and searching for customers at the POS is now fully restored.

We have restored product search data for all affected retailers. Lists of products and searching for products tag at POS are partially restored. The following product fields haven't been backfilled yet: retail_prices, tags and product_codes.

We are still working on restoring the remaining historical sales data.
Posted Nov 03, 2020 - 22:05 UTC
Update
An update on the status of restoring older data into our search indexes.

We have restored customer searches for all affected retailers, lists of customers and searching for customers at the POS is now fully restored.

We have restored product search data for all affected retailers. Lists of products and searching for products tag at POS are partially restored. The following product fields haven't been backfilled yet: retail_prices, tags and product_codes.

We are still working on restoring the remaining historical sales data and will update this page when we have a reliable ETA.
Posted Nov 03, 2020 - 19:47 UTC
Update
An update on the status of restoring historical product search data into our search indexes. We have fully restored product search data for all affected retailers.

Customer searches, lists of customers, lists of products and searching for products at the POS are fully restored.
Posted Nov 03, 2020 - 16:27 UTC
Update
Product search data has been restored for a subset of our retailers and the processes are running to restore this data for the remaining retailers. While this search data rebuilds you can continue scanning barcodes and using vend's quick keys.

We expect this data to finish restoring over the next few hours.
Posted Nov 03, 2020 - 08:47 UTC
Update
An update on the status of restoring older data into our search indexes. We have restored customer searches for all affected retailers, lists of customers and searching for customers at the POS is now fully restored. We are continuing to restore older product data to make it available in product lists, and searches at the POS.
Posted Nov 03, 2020 - 08:00 UTC
Update
We have successfully restored the most recent 10 days worth of sales, customer and product data, and have confirmed that newly created sales, products and customers are available in the search indexes. We are still working on restoring the remaining historical values at present and will update this page when we have a reliable ETA. Scanning and quick keys will remain working for historical values.
Posted Nov 03, 2020 - 06:32 UTC
Update
We have successfully restored the most recent 10 days worth of sales, customer and product data, and have confirmed that newly created sales, products and customers are available in the search indexes. We are still working on restoring the remaining historical values at present and will update this page when we have a reliable ETA.
Posted Nov 03, 2020 - 05:58 UTC
Update
We have successfully restored the most recent 10 days worth of sales, customer and product data, and have confirmed that newly created sales, products and customers are available in the search indexes. We are restoring the remaining historical values at present and will update this page when we have a reliable ETA.
Posted Nov 03, 2020 - 02:59 UTC
Update
We have begun rebuilding all the search indexes, we have prioritized recovering recent data first and anticipate having the last 10 days worth of sales, customers and products up to date within an hour.

In parallel we are rebuilding older data too and will update this page as we have a reliable ETA.
Posted Nov 03, 2020 - 01:44 UTC
Identified
We have identified the issue causing errors for retailers searching for products, customers and some sales. We are now rebuilding the search indexes. While this process runs you may notice missing data or empty results. No data has been lost. We will provide updates once we have a robust estimate for completion.
Posted Nov 03, 2020 - 00:31 UTC
Update
We are continuing to investigate an issue causing Product / Customer search to not display results.
Posted Nov 03, 2020 - 00:18 UTC
Update
We are continuing to investigate an issue causing Product / Customer search to not display results.
Posted Nov 02, 2020 - 23:54 UTC
Update
We are continuing to investigate an issue causing Product / Customer search to not display results.
Posted Nov 02, 2020 - 23:18 UTC
Investigating
We're currently investigating an issue causing Product / Customer search to not display results. Thanks for your patience, we'll keep you informed with updates as they arise.
Posted Nov 02, 2020 - 22:44 UTC
This incident affected: POS (Register for Mac & PC, Register for iPad).