Out of Date Sales History
Incident Report for Vend
Resolved
This incident is resolved. Sorry for the inconvenience.
Posted Jun 13, 2020 - 21:50 UTC
Identified
We've identified the issue and are resolving it. Sales will begin to appear in history.
Posted Jun 13, 2020 - 21:26 UTC
Investigating
We’re currently investigating an issue causing Sales History to return out-of-date results to some Vend retailers. Thanks for your patience, we’ll keep you informed with updates as they arise.
Posted Jun 13, 2020 - 21:15 UTC