Unable to complete payments and pair terminals with Paymentsense
Incident Report for Lightspeed
Resolved
The issue has been identified and resolved by PaymentSense.
Posted Mar 02, 2022 - 11:43 UTC
Investigating
Some retailers are experiencing issues trying to take payments and pair terminals with PaymentSense. Retailers get a blank screen. We are investigating the issue
Posted Mar 02, 2022 - 10:37 UTC