Gift Card and Gift Certificate Payments
Incident Report for Vend
Resolved
This incident has been resolved.
Posted Jun 24, 2020 - 06:23 UTC
Investigating
We are looking into reports that some Gift Card payment types are showing incorrectly, or with an incorrect name, we are investigating the issue now.
Posted Jun 24, 2020 - 03:21 UTC
This incident affected: POS (Gift Cards & Store Credits).