Marketing site (Vendhq.com) is not responding.
Incident Report for Lightspeed
Resolved
This incident has been resolved.
Posted Mar 29, 2022 - 00:45 UTC
Investigating
We are aware of the issue that prevents our customers from accessing our marketing site (vendhq.com). We are currently working to fix this. Thank you for your patience.
Posted Mar 29, 2022 - 00:06 UTC
This incident affected: www.vendhq.com.