Some retailers are unable to load the sell screen consistently
Incident Report for Lightspeed
Resolved
This incident has been resolved.
Posted Dec 31, 2021 - 05:05 UTC
Monitoring
We’ve deployed a fix and will continue monitoring to make sure there are no further disruptions.
Posted Dec 31, 2021 - 04:48 UTC
Investigating
We're investigating an issue that is causing some retailers to be unable to load the sell screen consistently.
Posted Dec 31, 2021 - 03:15 UTC
This incident affected: Lightspeed Retail (X-Series) (Retail POS, Retail POS for iPadOS).