Issues while processing payments with PaymentSense
Incident Report for Vend
Resolved
This incident is now resolved. Thanks for your patience. Please get in touch with Support if you continue to experience any issues.
Posted Dec 12, 2020 - 21:16 UTC
Monitoring
We're seeing reports of restored payment functionality from previously affected retailers.
We'll keep monitoring for any further issues.
Posted Dec 12, 2020 - 14:13 UTC
Investigating
We’re currently investigating an issue affecting our retailers using PaymentSense terminals. Please bear with us, we’ll keep you informed with status updates as they come.
Posted Dec 12, 2020 - 11:30 UTC
This incident affected: POS (Register for Mac & PC).