Out of Date Sales History for a Subset of Retailers
Incident Report for Vend
Resolved
This incident has been resolved.
Posted Mar 05, 2021 - 00:27 UTC
Investigating
We’re currently investigating an issue causing Sales History to return out-of-date results to a subset of Vend retailers. Thanks for your patience, we’ll keep you informed with updates as they arise.
Posted Mar 04, 2021 - 23:36 UTC